Requirements

These are the requirements for our SDK

ItemNotes
Api levelAndroid API level 21 (Android 5.0) or higher
Gradle versionGradle 7.4.0 or higher
Android studioAndroid Studio 3.1.3 or higher (You can use other development tools to build your Android app. Our documentation demonstrates how to implement this SDK via Android Studio.)
InternetInternet connectivity during playback
Brid Tv accountIn order to use our SDK, you must have a registered account with one of our usage plans. You can choose from our various plans based on your specific needs.

📘

Please ensure that your development environment meets these requirements before integrating our SDK into your app.

If you have any questions or concerns regarding the requirements, please don't hesitate to ask.

Documentation

This developer guide contains best practices for implementing our SDK and is designed to assist you in the integration process. Additionally, we provide comprehensive documentation for each class in our SDK reference.

Third-Party Libraries and Frameworks

The BridTv Android SDK supports Google IMA, Google ExoPlayer, Google Cast and Open Measurement.

Terms of service

By using the Brid Tv Android SDK, you are agreeing to our Terms & Conditions. We recommend reviewing our terms of service carefully before integrating our SDK into your application.